QuickBooks and Vista - Compatibility Issues

Learn about QuickBooks and Vista

Subscribe to Adventures in QB!
and get the FREE Report,
"The 7 Most Common Mistakes
People Make in QB
...and How to Fix Them!"

Available for immediate download.

Email

First Name

Then

Don't worry -- your e-mail address is totally secure.
I promise to use it only to send you Adventures in QB.

Time to Upgrade? Get Up To 20% Off QB Products + Free Shipping

Are you having problems with getting QuickBooks to run on Vista? You are not alone. Many people don't realize that their older versions of QB will not run on Microsoft's newest operating system.

Which versions of QB run on Vista?

The official answer is that only QB 2007 and later are designed to run on it.

Why are only the newest versions supported on Vista?

It's not really a support issue - in other words, it's not Microsoft's fault that QB doesn't run on it.

You may know about the "Windows XP certification" that came out in 2001. In a nutshell, Microsoft came up with a list of programming techniques that were considered potentially harmful to computers. These techniques leave the OS open for attack. One of these techniques is something Intuit continued to use, up through QB 2006. This is why we never saw the Windows Certification logo on the side of a QuickBooks box.

At that time, becoming Windows XP certified was just a suggestion from Microsoft - it was not a requirement, and software that was not certified, software that continued to use the harmful techniques, could continue to run on Windows XP.

No more. Microsoft has put it's foot down with it's newest OS. In order to run on Vista, the software must not use the dangerous techniques. And this is why older versions of QB cannot run on it, since they use one of those techniques, and Intuit really cannot update them.

Which dangerous technique did Intuit use?

Do you know why people who use Macintosh's never have to deal with viruses in their software or OS? It's because they are forced by the operating system to only run in a non-administrator mode. If Windows XP was required to run in this mode, then every worm, virus, Trojan horse, etc., would be rendered inoperable. Intuit never obtained the Windows XP certification, because it used the Windows registry for certain tasks, and that portion of the registry required full administrative access.

Why can't Intuit update older versions of QB to eliminate this technique?

I don't really know, but I do know that third party add-on software for QuickBooks also uses this technique. If Intuit updated older versions of QB, the third party software would not be able to work. Perhaps this is one reason why.

Final Thoughts

There are workarounds to try to get your older version of QB to run on MSVista. Quite honestly, I do not recommend them. Although I'm sure some of them work, in my view your time is better spent simply running your business rather than spending potential hours and hours trying to figure out and use the workaround.

With my best wishes for your success and happiness....

Jennifer Thieme's signature

Prefer to search instead of browse?


Want personal help with QuickBooks for Vista? Contact Jennifer

Return to Home Page of QuickBooks Answers